Thursday, May 3, 2012

Installing and Configuring PostGres SQL Server

Doing some Database migrations, I had to install a database server from scratch, and it had to be PostGres, 8.4.  So Here is the sequence of events that I did in order to get this up and running....

This is running on a CentOS 6.2, which I created as a VM on a Citrix 6.0 XenCenter.  Gave it 3Gb of RAM, as I have to import a 3Gb Database.

Step 1: Get Postgres installed.
The easiest way to do this is with yum, if you have redhat then configure your yum repositories or if you are registered with RHN, just do:

I did that, this is the output I get when I did it again (obviously, but Im just showing you the results)

root@POSTGRES-XEN [ ~ ]# yum install postgresql
Loaded plugins: fastestmirror, refresh-packagekit, security
Loading mirror speeds from cached hostfile
 * base: centos.omnispring.com
 * extras: centos.omnispring.com
 * updates: mirror.lug.udel.edu
Setting up Install Process
Package postgresql-8.4.9-1.el6_1.1.x86_64 already installed and latest version
Nothing to do
root@POSTGRES-XEN [ ~ ]#

Now, we will su into the user created, postgres, and start the work:


This is what you will get:

root@POSTGRES-XEN [ ~ ]# su - postgres
postgres@POSTGRES-XEN [ ~ ]$ initdb -D ./data
The files belonging to this database system will be owned by user "postgres".
This user must also own the server process.

The database cluster will be initialized with locale en_US.UTF-8.
The default database encoding has accordingly been set to UTF8.
The default text search configuration will be set to "english".

fixing permissions on existing directory ./data ... ok
creating subdirectories ... ok
selecting default max_connections ... 100
selecting default shared_buffers ... 32MB
creating configuration files ... ok
creating template1 database in ./data/base/1 ... ok
initializing pg_authid ... ok
initializing dependencies ... ok
creating system views ... ok
loading system objects' descriptions ... ok
creating conversions ... ok
creating dictionaries ... ok
setting privileges on built-in objects ... ok
creating information schema ... ok
vacuuming database template1 ... ok
copying template1 to template0 ... ok
copying template1 to postgres ... ok

WARNING: enabling "trust" authentication for local connections
You can change this by editing pg_hba.conf or using the -A option the
next time you run initdb.

Success. You can now start the database server using:

    postgres -D ./data
or
    pg_ctl -D ./data -l logfile start


Now, we need to start the database, in the way it shows above:

pg_ctl -D ./data -l logfile start

(pg_ctl is at /usr/bin/ )



Step 2, is let's create the database and the user accessing it:

as the user postgres, execute:

createdb --owner=confluence confluence

then, go into the postgres console by typing:

postgres@POSTGRES-XEN [ ~ ]$ psql
psql (8.4.9)
Type "help" for help.

postgres=#\l

(You can list the databases like this; just type forward slash and small l:)

\l


 You can see the database we created, to see size information about it, you can type:

postgres=# SELECT pg_size_pretty(pg_database_size('confluence'));

This is not so applicable now, but I needed it to see the size of this 3Gb database.


We dont have a user yet, so let's create one:

postgres=# CREATE USER confluence WITH PASSWORD 'myPassword';

If you want to change password, you would do:

postgres=# ALTER USER confluence WITH PASSWORD 'NewPassword';






(this was a database for a confluence installation)

To Delete a database (watch out!!) you do this:

postgres=# DROP DATABASE confluence ;

You can also see all the options that the database is running with with:

postgres=# SHOW ALL;



To see current activity on the database, you can do this:

select * from pg_stat_activity where current_query not like '<%';

You will get something similiar to this:


Next, we will give privilidges on the database to this new user:

postgres=# GRANT ALL PRIVILEGES ON DATABASE confluence to confluence;


To see what permissions your users have do:

SELECT * FROM pg_user;

You will get something like this:

postgres=# SELECT * FROM pg_user;
  usename   | usesysid | usecreatedb | usesuper | usecatupd |  passwd  | valuntil | useconfig
------------+----------+-------------+----------+-----------+----------+----------+-----------
 postgres   |       10 | t           | t        | t         | ******** |          |
 confluence |    16384 | f           | f        | f         | ******** |          |
(2 rows)

Now we will export the data from the origin database, I do this with this script:

pg_dump \
    --file=postgres_confluence_data.ORIGINAL.dump \
    --format=custom \
    --ignore-version \
    --schema=public \
    --schema=otherschema \
    --no-owner \
    --verbose \
    --no-privileges \
     confluence





This is done from the Linux command line, not the Postgres SQL prompt.

however, in my case, since I was working on a very low end box, I had to change some kernel parameters, and add some swap space:

  sysctl -w kernel.shmall=4194304
  echo "67108864" > /proc/sys/kernel/shmmax

(you can also put this in  /etc/sysctl.conf permanently, not in the format though!)

Then I created a 8Gb swap file (Box only had 1Gb vRAM)


root@POSTGRES-XEN [ ~ ]# dd if=/dev/zero of=/swapfilenew bs=1024 count=8388608
root@POSTGRES-XEN [ ~ ]# mkswap /swapfilenew
root@POSTGRES-XEN [ ~ ]# chown root:root /swapfilenew
root@POSTGRES-XEN [ ~ ]# chmod 0600 /swapfilenew
root@POSTGRES-XEN [ ~ ]# swapon /swapfilenew

When I have this file,  I then restore it to the new database like this:


pg_restore \
    --format=custom \
    --ignore-version \
    --no-owner \
    --no-privileges \
    --verbose \
    -U confluence -d confluence \
    ~postgres/postgres_confluence_data.ORIGINAL.dump


After the database is comfortably sitting in the new location, we want to also make sure that
it can be accessed.

You have to edit your pg_hba.conf and go to the bottom and add your networks that you trust to connect to the database:

# IPv6 local connections:
host    all         all         ::1/128               trust        
host    all         all         12.18.96.0/24               trust    
host    all         all         10.18.97.0/24               trust     
host    all         all         10.13.235.0/24               trust
host    all         all         10.15.194.0/24               trust

Also, go to your postgresql.conf file and uncomment this line:

listen_addresses = '*'

Then go to your other server and telnet to port 5432 or run a query from there. Watch out if it's an out the box linux server, that iptables is not running, in my case I disabled it:

root@POSTGRES-XEN [ ~ ]# service iptables stop
iptables: Flushing firewall rules:                         [  OK  ]
iptables: Setting chains to policy ACCEPT: filter          [  OK  ]
iptables: Unloading modules:                               [  OK  ]
root@POSTGRES-XEN [ ~ ]#
root@POSTGRES-XEN [ ~ ]# chkconfig iptables off
root@POSTGRES-XEN [ ~ ]# chkconfig --list | grep iptables
iptables        0:off   1:off   2:off   3:off   4:off   5:off   6:off
root@POSTGRES-XEN [ ~ ]#


You can also check to see if the daemon is listening:

root@POSTGRES-XEN [ ~ ]# netstat -alnp  |grep 5432
tcp        0      0 0.0.0.0:5432                0.0.0.0:*                   LISTEN      2828/postgres      
tcp        0      0 12.18.97.12:5432           10.13.235.8:45189          ESTABLISHED 10894/postgres     
tcp        0      0 :::5432                     :::*                        LISTEN      2828/postgres      
unix  2      [ ACC ]     STREAM     LISTENING     22361  2828/postgres       /tmp/.s.PGSQL.5432
root@POSTGRES-XEN [ ~ ]#

That's about it... I will hopefully do a follow up article on the confluence server as well.





Wednesday, April 11, 2012

Setting up a Cisco 3750 Master with Stack for VOIP & Data


Posted by: Boaz Minitzer


Cisco 3750 Stack

This configuration was for a stack of 6 3750 family of switches, these as you can see below had a vlan for VOIP  (101) and various vlans for Data, wireless, and VPN's to a few locations.  
I left the IP's in there, as this system has now been replaced and is no longer in service, and ignore the description below of "CiscoPhone" (Configuring a QoS policy typically requires classifying traffic into classes, configuring policies applied to those traffic classes, and attaching policies to ports.)


Although it could get confusing (that this was a Cisco VOIP system - aka CallManager) this system was actually for an Interactive Intelligence system which at the time was much more efficient than CallManager. (I dont know about today, would have to re-take a look)


You can take a look at configuring CoS and QoS(Class of Service, Quality of Service) in regards to VoIP here:
http://www.cisco.com/en/US/docs/switches/lan/catalyst3750/software/release/12.2_55_se/configuration/guide/swqos.html (This is for IOS Release 12.2(55)SE)


Initial Stack Setup


  • Starting out with a console cable, connect to the switch you are designating as master.  Build a configuration that will apply to the entire switch stack.  If you have any “slave” switches that will be added, make sure to “write erase” and delete the VLAN information stored in “vlan.dat.”
  • Provision this switch as master using the following command: “switch 1 provision [switch-type].”  Repeat this for every switch.  (see in the config below how that shows in my example)
  • If Needed, Set the master switch priority highest using the “switch 1 priority 15” command in global configuration mode.
  • If you have switches that are numbered incorrectly, use the “switch 1 renumber [number]” command.  
  • Connect the Cisco StackWise cables  diagonally from Switch 1 to Switch 2, from Switch 2 to Switch 3, etc. Then, cable the top-most switch to the bottom master switch (if starting from bottom).
  • Verify that provisioning was successful using the command “show switch detail.”

Ok, and now on to the configuration.....! 



!
! Last configuration change at 09:29:10 PDT Tue Apr 14 2010
! NVRAM config last updated at 17:44:25 PDT Mon Apr 13 2010
!
version 12.2
no service pad
service timestamps debug datetime localtime
service timestamps log datetime localtime
service password-encryption
!
hostname BME-555-1F-3750
!
boot-start-marker
boot-end-marker
!
logging buffered 40960
no logging console
enable secret 5 <pass removed>
!
no aaa new-model
clock timezone PST -8
clock summer-time PDT recurring
switch 1 provision ws-c3750g-24ts-1u
switch 2 provision ws-c3750g-24ts-1u
switch 3 provision ws-c3750-48p
switch 4 provision ws-c3750-48p
switch 5 provision ws-c3750-48p
system mtu routing 1500
ip subnet-zero
ip routing
ip name-server 192.168.100.26
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.103.1 192.168.103.29
ip dhcp excluded-address 192.168.104.1 192.168.104.29
ip dhcp excluded-address 10.0.120.1 10.0.120.39
!
ip dhcp pool BME_WiFi_User
   network 192.168.103.0 255.255.255.0
   default-router 192.168.103.1 
   dns-server 192.168.100.65 192.168.100.26 
   domain-name LA7.local
   lease 0 10
!
ip dhcp pool BME_WiFi_Guest
   network 192.168.104.0 255.255.255.192
   default-router 192.168.104.1 
   dns-server 64.105.132.250 64.105.132.252 
   lease 0 2
!
ip dhcp pool TMP_TFTP_Pool
   network 10.0.120.0 255.255.255.0
   default-router 10.0.120.1 
   domain-name LA7.local
   dns-server 192.168.100.21 192.168.100.22 
   option 66 ip 10.0.101.21 10.0.101.22 
   lease 0 2
!
!
!
mls qos map policed-dscp  24 26 46 to 0
mls qos map cos-dscp 0 8 16 24 32 46 48 56
mls qos srr-queue input bandwidth 90 10
mls qos srr-queue input threshold 1 8 16
mls qos srr-queue input threshold 2 34 66
mls qos srr-queue input buffers 67 33 
mls qos srr-queue input cos-map queue 1 threshold 2  1
mls qos srr-queue input cos-map queue 1 threshold 3  0
mls qos srr-queue input cos-map queue 2 threshold 1  2
mls qos srr-queue input cos-map queue 2 threshold 2  4 6 7
mls qos srr-queue input cos-map queue 2 threshold 3  3 5
mls qos srr-queue input dscp-map queue 1 threshold 2  9 10 11 12 13 14 15
mls qos srr-queue input dscp-map queue 1 threshold 3  0 1 2 3 4 5 6 7
mls qos srr-queue input dscp-map queue 1 threshold 3  32
mls qos srr-queue input dscp-map queue 2 threshold 1  16 17 18 19 20 21 22 23
mls qos srr-queue input dscp-map queue 2 threshold 2  33 34 35 36 37 38 39 48
mls qos srr-queue input dscp-map queue 2 threshold 2  49 50 51 52 53 54 55 56
mls qos srr-queue input dscp-map queue 2 threshold 2  57 58 59 60 61 62 63
mls qos srr-queue input dscp-map queue 2 threshold 3  24 25 26 27 28 29 30 31
mls qos srr-queue input dscp-map queue 2 threshold 3  40 41 42 43 44 45 46 47
mls qos srr-queue output cos-map queue 1 threshold 3  5
mls qos srr-queue output cos-map queue 2 threshold 3  3 6 7
mls qos srr-queue output cos-map queue 3 threshold 3  2 4
mls qos srr-queue output cos-map queue 4 threshold 2  1
mls qos srr-queue output cos-map queue 4 threshold 3  0
mls qos srr-queue output dscp-map queue 1 threshold 3  40 41 42 43 44 45 46 47
mls qos srr-queue output dscp-map queue 2 threshold 3  24 25 26 27 28 29 30 31
mls qos srr-queue output dscp-map queue 2 threshold 3  48 49 50 51 52 53 54 55
mls qos srr-queue output dscp-map queue 2 threshold 3  56 57 58 59 60 61 62 63
mls qos srr-queue output dscp-map queue 3 threshold 3  16 17 18 19 20 21 22 23
mls qos srr-queue output dscp-map queue 3 threshold 3  32 33 34 35 36 37 38 39
mls qos srr-queue output dscp-map queue 4 threshold 1  8
mls qos srr-queue output dscp-map queue 4 threshold 2  9 10 11 12 13 14 15
mls qos srr-queue output dscp-map queue 4 threshold 3  0 1 2 3 4 5 6 7
mls qos queue-set output 1 threshold 1 138 138 92 138
mls qos queue-set output 1 threshold 2 138 138 92 400
mls qos queue-set output 1 threshold 3 36 77 100 318
mls qos queue-set output 1 threshold 4 20 50 67 400
mls qos queue-set output 2 threshold 1 149 149 100 149
mls qos queue-set output 2 threshold 2 118 118 100 235
mls qos queue-set output 2 threshold 3 41 68 100 272
mls qos queue-set output 2 threshold 4 42 72 100 242
mls qos queue-set output 1 buffers 10 10 26 54
mls qos queue-set output 2 buffers 16 6 17 61
mls qos
!
!
!
errdisable recovery cause udld
errdisable recovery cause bpduguard
errdisable recovery cause security-violation
errdisable recovery cause channel-misconfig
errdisable recovery cause pagp-flap
errdisable recovery cause dtp-flap
errdisable recovery cause link-flap
errdisable recovery cause sfp-config-mismatch
errdisable recovery cause gbic-invalid
errdisable recovery cause l2ptguard
errdisable recovery cause psecure-violation
errdisable recovery cause port-mode-failure
errdisable recovery cause dhcp-rate-limit
errdisable recovery cause mac-limit
errdisable recovery cause vmps
errdisable recovery cause storm-control
errdisable recovery cause inline-power
errdisable recovery cause arp-inspection
errdisable recovery cause loopback
errdisable recovery cause small-frame
errdisable recovery interval 92
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
spanning-tree vlan 1-2,10-12,101-102 priority 24576
!
vlan internal allocation policy ascending
!
!
class-map match-all AutoQoS-VoIP-RTP-Trust
 match ip dscp ef 
class-map match-all AutoQoS-VoIP-Control-Trust
 match ip dscp cs3  af31 
!
!
policy-map AutoQoS-Police-CiscoPhone
 class AutoQoS-VoIP-RTP-Trust
  set dscp ef
  police 320000 8000 exceed-action policed-dscp-transmit
 class AutoQoS-VoIP-Control-Trust
  set dscp cs3
  police 32000 8000 exceed-action policed-dscp-transmit
!
!
!
interface Port-channel1
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet1/0/1
 description PublicInternet-64.147.18.80/28 - Cox connection
 switchport access vlan 5
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet1/0/2
 description PublicInternet-64.147.18.80/28 - ASA5510 Outside
 switchport access vlan 5
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet1/0/3
 description To ASA5510 E0/1 Inside 192.168.0.1
 switchport access vlan 2
 switchport mode access
 speed 100
 duplex full
 spanning-tree portfast
!
interface GigabitEthernet1/0/4
 description To ASA CSC SSM 192.168.0.4/24
 switchport access vlan 2
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet1/0/5
 description Data Servers
 switchport access vlan 2
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet1/0/6
 description Data Servers
 switchport access vlan 2
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet1/0/7
 description Data Servers
 switchport access vlan 10
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet1/0/8
 description Data Servers
 switchport access vlan 10
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet1/0/9
 description Data Servers
 switchport access vlan 10
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet1/0/10
 description Data Servers
 switchport access vlan 10
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet1/0/11
 description Data Servers
 switchport access vlan 10
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet1/0/12
 description Data Servers
 switchport access vlan 10
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet1/0/13
 description Data Servers
 switchport access vlan 10
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet1/0/14
 description Data Servers
 switchport access vlan 10
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet1/0/15
 description Data Servers
 switchport access vlan 10
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet1/0/16
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet1/0/17
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet1/0/18
 description Voice Server and Gateway
 switchport access vlan 101
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet1/0/19
 description EIC1 - 10.0.101.21
 switchport access vlan 101
 switchport mode access
 speed 100
 duplex full
 srr-queue bandwidth share 10 10 60 20
 queue-set 2
 priority-queue out 
 mls qos trust cos
 auto qos voip trust 
 spanning-tree portfast
!
interface GigabitEthernet1/0/20
 description Voice Server and Gateway
 switchport access vlan 101
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet1/0/21
 description Voice Server and Gateway
 switchport access vlan 101
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet1/0/22
 description Voice Server and Gateway
 switchport access vlan 101
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet1/0/23
 description Voice Server and Gateway
 switchport access vlan 101
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet1/0/24
 switchport access vlan 101
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet1/0/25
 switchport trunk encapsulation dot1q
 switchport mode trunk
 srr-queue bandwidth share 10 10 60 20
 queue-set 2
 priority-queue out 
 mls qos trust dscp
 auto qos voip trust 
 channel-group 1 mode on
!
interface GigabitEthernet1/0/26
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet1/0/27
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet1/0/28
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet2/0/1
 description PublicInternet-64.147.18.80/28 - VPN Rtr Gi0/0
 switchport access vlan 5
 switchport mode access
 load-interval 120
 spanning-tree portfast
!
interface GigabitEthernet2/0/2
 description PublicInternet-64.147.18.80/28
 switchport access vlan 5
 switchport mode access
 load-interval 120
 spanning-tree portfast
!
interface GigabitEthernet2/0/3
 switchport access vlan 5
 switchport mode access
 load-interval 120
 spanning-tree portfast
!
interface GigabitEthernet2/0/4
 switchport access vlan 103
 switchport mode access
 load-interval 120
 spanning-tree portfast
!
interface GigabitEthernet2/0/5
 description VPN Rtr inside Gi0/1 192.168.0.254
 switchport access vlan 2
 switchport mode access
 load-interval 120
 spanning-tree portfast
!
interface GigabitEthernet2/0/6
 description SonicWall VPN NAT 192.168.0.89
 switchport access vlan 2
 switchport mode access
 load-interval 120
 spanning-tree portfast
!
interface GigabitEthernet2/0/7
 description Data Servers
 switchport access vlan 10
 switchport mode access
 load-interval 120
 spanning-tree portfast
!
interface GigabitEthernet2/0/8
 description Data Servers
 switchport access vlan 10
 switchport mode access
 load-interval 120
 spanning-tree portfast
!
interface GigabitEthernet2/0/9
 description Data Servers
 switchport access vlan 10
 switchport mode access
 load-interval 120
 spanning-tree portfast
!
interface GigabitEthernet2/0/10
 description Data Servers
 switchport access vlan 10
 switchport mode access
 load-interval 120
 spanning-tree portfast
!
interface GigabitEthernet2/0/11
 description Data Servers
 switchport access vlan 10
 switchport trunk encapsulation dot1q
 switchport mode access
 load-interval 120
 spanning-tree portfast
!
interface GigabitEthernet2/0/12
 description Data Servers
 switchport access vlan 10
 switchport trunk encapsulation dot1q
 switchport mode access
 load-interval 120
 spanning-tree portfast
!
interface GigabitEthernet2/0/13
 description Data Servers
 switchport access vlan 10
 switchport trunk encapsulation dot1q
 switchport mode access
 load-interval 120
 spanning-tree portfast
!
interface GigabitEthernet2/0/14
 description Data Servers
 switchport access vlan 10
 switchport trunk encapsulation dot1q
 switchport mode access
 load-interval 120
 spanning-tree portfast
!
interface GigabitEthernet2/0/15
 description Data Servers
 switchport access vlan 10
 switchport mode access
 load-interval 120
 spanning-tree portfast
!
interface GigabitEthernet2/0/16
 switchport trunk encapsulation dot1q
 switchport mode trunk
 load-interval 120
!
interface GigabitEthernet2/0/17
 description HQ-Camera
 switchport access vlan 9
 switchport mode access
 load-interval 120
!
interface GigabitEthernet2/0/18
 description HQ-Camera
 switchport access vlan 9
 switchport mode access
 load-interval 120
 spanning-tree portfast
!
interface GigabitEthernet2/0/19
 description EIC2 - 10.0.101.22
 switchport access vlan 101
 switchport mode access
 load-interval 120
 speed 100
 duplex full
 srr-queue bandwidth share 10 10 60 20
 queue-set 2
 priority-queue out 
 mls qos trust cos
 auto qos voip trust 
 spanning-tree portfast
!
interface GigabitEthernet2/0/20
 description Voice Server and Gateway
 switchport access vlan 101
 switchport mode access
 load-interval 120
 spanning-tree portfast
!
interface GigabitEthernet2/0/21
 description Voice Server and Gateway
 switchport access vlan 101
 switchport mode access
 load-interval 120
 spanning-tree portfast
!
interface GigabitEthernet2/0/22
 description Voice Server and Gateway
 switchport access vlan 101
 switchport mode access
 load-interval 120
 spanning-tree portfast
!
interface GigabitEthernet2/0/23
 description Voice Server and Gateway
 switchport access vlan 101
 switchport mode access
 load-interval 120
 spanning-tree portfast
!
interface GigabitEthernet2/0/24
 description Voice Server and Gateway
 switchport access vlan 101
 switchport mode access
 load-interval 120
 spanning-tree portfast
!
interface GigabitEthernet2/0/25
 switchport trunk encapsulation dot1q
 switchport mode trunk
 srr-queue bandwidth share 10 10 60 20
 queue-set 2
 priority-queue out 
 mls qos trust dscp
 auto qos voip trust 
 channel-group 1 mode on
!
interface GigabitEthernet2/0/26
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet2/0/27
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet2/0/28
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface FastEthernet3/0/1
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet3/0/2
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet3/0/3
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet3/0/4
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet3/0/5
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet3/0/6
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet3/0/7
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet3/0/8
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet3/0/9
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet3/0/10
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet3/0/11
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet3/0/12
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet3/0/13
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet3/0/14
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet3/0/15
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet3/0/16
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet3/0/17
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet3/0/18
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet3/0/19
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet3/0/20
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet3/0/21
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet3/0/22
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet3/0/23
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet3/0/24
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet3/0/25
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet3/0/26
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet3/0/27
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet3/0/28
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet3/0/29
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet3/0/30
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet3/0/31
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet3/0/32
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet3/0/33
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet3/0/34
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet3/0/35
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet3/0/36
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet3/0/37
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet3/0/38
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet3/0/39
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet3/0/40
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet3/0/41
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet3/0/42
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet3/0/43
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet3/0/44
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet3/0/45
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet3/0/46
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet3/0/47
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet3/0/48
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface GigabitEthernet3/0/1
!
interface GigabitEthernet3/0/2
!
interface GigabitEthernet3/0/3
!
interface GigabitEthernet3/0/4
!
interface FastEthernet4/0/1
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet4/0/2
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet4/0/3
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet4/0/4
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet4/0/5
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet4/0/6
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet4/0/7
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet4/0/8
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet4/0/9
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet4/0/10
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet4/0/11
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet4/0/12
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet4/0/13
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet4/0/14
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet4/0/15
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet4/0/16
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet4/0/17
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet4/0/18
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet4/0/19
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet4/0/20
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet4/0/21
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet4/0/22
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet4/0/23
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet4/0/24
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet4/0/25
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet4/0/26
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet4/0/27
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet4/0/28
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet4/0/29
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet4/0/30
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet4/0/31
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet4/0/32
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet4/0/33
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet4/0/34
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet4/0/35
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet4/0/36
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet4/0/37
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet4/0/38
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet4/0/39
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet4/0/40
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet4/0/41
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet4/0/42
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet4/0/43
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet4/0/44
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet4/0/45
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet4/0/46
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet4/0/47
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet4/0/48
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface GigabitEthernet4/0/1
!
interface GigabitEthernet4/0/2
!
interface GigabitEthernet4/0/3
!
interface GigabitEthernet4/0/4
!
interface FastEthernet5/0/1
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet5/0/2
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet5/0/3
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet5/0/4
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet5/0/5
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet5/0/6
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet5/0/7
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet5/0/8
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet5/0/9
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet5/0/10
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet5/0/11
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet5/0/12
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet5/0/13
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet5/0/14
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet5/0/15
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet5/0/16
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet5/0/17
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet5/0/18
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet5/0/19
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet5/0/20
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet5/0/21
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet5/0/22
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet5/0/23
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet5/0/24
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet5/0/25
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet5/0/26
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet5/0/27
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet5/0/28
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet5/0/29
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet5/0/30
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet5/0/31
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet5/0/32
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet5/0/33
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet5/0/34
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet5/0/35
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet5/0/36
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet5/0/37
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet5/0/38
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet5/0/39
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet5/0/40
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet5/0/41
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet5/0/42
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet5/0/43
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet5/0/44
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet5/0/45
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet5/0/46
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet5/0/47
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet5/0/48
 switchport access vlan 11
 switchport voice vlan 101
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface GigabitEthernet5/0/1
!
interface GigabitEthernet5/0/2
!
interface GigabitEthernet5/0/3
!
interface GigabitEthernet5/0/4
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan2
 ip address 192.168.0.2 255.255.255.0
!
interface Vlan3
 ip address 192.168.103.1 255.255.255.0
!
interface Vlan4
 ip address 192.168.104.1 255.255.255.192
!
interface Vlan9
 ip address 192.168.105.1 255.255.255.0
!
interface Vlan10
 ip address 192.168.100.1 255.255.255.0
!
interface Vlan11
 ip address 192.168.101.1 255.255.255.0
 ip helper-address 192.168.100.65
!
interface Vlan12
 ip address 192.168.102.1 255.255.255.0
 ip helper-address 192.168.100.65
!
interface Vlan101
 ip address 10.0.101.1 255.255.255.0
 ip helper-address 192.168.100.65
!
interface Vlan102
 ip address 10.0.102.1 255.255.255.0
 ip helper-address 192.168.100.65
!
interface Vlan103
 no ip address
 shutdown
!
router rip
 version 2
 redistribute connected
 redistribute static metric 4 route-map Static-RMap
 network 192.168.0.0
 no auto-summary
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.0.1
ip route 192.168.98.0 255.255.254.0 192.168.0.254
ip route 192.168.104.128 255.255.255.192 192.168.0.1
ip http server
!
ip access-list standard Static-Acl
 permit 192.168.104.128 0.0.0.63
!
route-map Static-RMap permit 10
 match ip address Static-Acl
!
snmp-server community BMESnmpRo RO
snmp-server community BMESnmp#RW RW
snmp-server location BME-LA
snmp-server contact Boaz Minitzer
!
control-plane
!
!
line con 0
line vty 0 4
 password 7 <pass removed>
 login
line vty 5 15
 no login
!
!
monitor session 1 source interface Gi1/0/3
monitor session 1 destination interface Gi2/0/23
monitor session 2 destination interface Gi1/0/23
ntp clock-period 36028647
ntp server 192.5.41.40
ntp server 198.123.30.132
end